A transaction output consists of two parts: a field that defines the count of satoshis assigned to the output, and the output script (“scriptPubKey”).
What is the best name for the field that determines how many satoshis the recipient gets?
Amount95.5%
Value0.0%
I’ll tell you below4.5%
22 votes \ poll ended
The value of a Satoshi is subjective and differs from person to person. As goods and services denominated in Bitcoin will all become less expensive over time, it seems more appropriate to keep this label constant over time and call it the Amount
reply
IMHO if the unit of measure is implicit/defined the term should be amount; amount+unit represents some "value".
reply
Thanks, I had not heard that distribution before, but that's helpful
reply
I'd say amount only because that's the name of the type in the source code https://github.com/bitcoin/bitcoin/blob/master/src/consensus/amount.h
// Copyright (c) 2009-2010 Satoshi Nakamoto // Copyright (c) 2009-2021 The Bitcoin Core developers // Distributed under the MIT software license, see the accompanying // file COPYING or http://www.opensource.org/licenses/mit-license.php. #ifndef BITCOIN_CONSENSUS_AMOUNT_H #define BITCOIN_CONSENSUS_AMOUNT_H #include <cstdint> /** Amount in satoshis (Can be negative) */ typedef int64_t CAmount; /** The amount of satoshis in one BTC. */ static constexpr CAmount COIN = 100000000; /** No amount larger than this (in satoshi) is valid. * * Note that this constant is *not* the total money supply, which in Bitcoin * currently happens to be less than 21,000,000 BTC for various reasons, but * rather a sanity check. As this sanity check is used by consensus-critical * validation code, the exact value of the MAX_MONEY constant is consensus * critical; in unusual circumstances like a(nother) overflow bug that allowed * for the creation of coins out of thin air modification could lead to a fork. * */ static constexpr CAmount MAX_MONEY = 21000000 * COIN; inline bool MoneyRange(const CAmount& nValue) { return (nValue >= 0 && nValue <= MAX_MONEY); } #endif // BITCOIN_CONSENSUS_AMOUNT_H
reply
Funny that creation of coins out of thin air is considered a bug in Bitcoin but a feature in fiat.
reply
Very good point, thanks
reply